問題
Google関連のサービス連携の際、以下のエラーが表示されることもございます。
考えられる原因
サードパーティによるすべての API アクセスをブロックする がオンになっている
Google Workspaceの管理画面 のセキュリティ >アクセスのデータ管理> APIの制御 にある サードパーティによるすべての API アクセスをブロックする がオンの場合、連携に失敗することもあります。

Google Workspace 管理コンソールへのAPIが制限付きになっている
Google Workspaceの管理画面 のセキュリティ >アクセスのデータ管理> APIの制御 > GOOGLEサービスを管理
https://admin.google.com/ac/owl/list?tab=services
にある Google Workspace 管理コンソール のアクセスポリシーが制限付きになっている場合、連携に失敗する場合があります。

当サービスを指名してブロックしている
Google Workspaceの管理画面 のセキュリティ > アクセスのデータ管理>APIの制御 > サードパーティ製アプリのアクセスを管理 で、以下のアプリケーションを検索して、アクセスステータスが ブロック中 または 制限付き になっている場合、連携に失敗する場合があります。

解決方法
上記で紹介したそれぞれの原因のブロック を 許可 することで解決可能です。
組織のポリシーにより、当サービスだけを特別に許可したい場合、以下の方法で、当サービスだけを許可できます。
- Google Workspaceの管理画面 の
セキュリティ>アクセスのデータ管理>APIの制御> サードパーティ製アプリのアクセスを管理 に移動します。

アプリを追加>OAuthアプリ名またはクライアントIDを選択します。

- クライアントIDに以下を入力して検索ボタンを実行。
Money Forward ITMCを選択します。

- 同じクライアントIDを選択し、

- アプリのアクセス権限を
信頼されている:すべてのGoogleサービスにアクセス可能を選んで、設定を実行します。


